SOLUTION: Projects with missing files


#1

After the latest deploy, some projects might have missing files in them, or they might not be able to start entirely.

If that’s the case, please let us know the project name so that we can restore it from a backup (that we did right before the deploy).

Sorry for the inconvenience :frowning: !


#2

#3

ashbot
sqlite.db is missing :frowning:


#4

:+1: just restored it


#5

I don’t know what you guys did, but a few nights ago our project disappeared and we were panicking! But it just randomly restored itself a few moments ago, so if the glitch staff have anything to do with it, THANKYOU SO MUCH!
Love from kayla-bot’s creators!


#6

The process restoring impacted projects has now complete. Let us know if you’re still having problems.


#7

#8

Hi, these projects aren’t starting - all the node/express stuff seems to have gone missing

face2pumpkin-twitter
santafacebot-twitter


#9

should be fixed :slight_smile:


#10

yes, they’re working properly again. thanks!


#11

Not sure if this is related in any way but I have a Python-based project :wink: where my pip-installed modules disappeared sometime in the last day or so. Not a big deal, - I can just re-install them - but when I try, I get a “Disk quota exceeded” error despite the Glitch UI showing only 31/200MB used.
Project name: radio-star-django on the off-chance there’s something to be investigated.


#12

but when I try, I get a “Disk quota exceeded” error despite the Glitch UI showing only 31/200MB used.

Was just about to post the same issue. I’ve tried a few things, but keep hitting the same error. Some modules seem to install fine (Gunicorn), but others don’t (there is a django directory in site-packages, but I get an error “no module named django-dispatch” when running the app, and the Disk quota exceeded error on installing.

The full error on pip3 install -r requirements.txt --user most recently is below, but it’s not always the same.

Could not install packages due to an EnvironmentError: [Errno 122] Disk quota exceeded: '/app/.local/lib/python3.5/site-packages/django/contr

ib/admin/locale/fa’

The full error on trying to install django by itself is:

Could not install packages due to an EnvironmentError: [Errno 122] Disk quota exceeded: '/app/.local/lib/python3.5/site-packages/django/contr

ib/flatpages/locale/is/LC_MESSAGES/django.mo

I also get the “Disk quote exceeded” error on:

rm -rf /app/.local/lib/python3.5

Here is a simple project that has the error:


#13

I also have seen the Disk quota exceeded error on a node project where I have tried to do npm install from the console (which had been a solution to a webpack issue I was having before).


#14

Sorry about that, we’re looking into the underlying cause.


#15

Any update on this? It seems like the issue is mostly fixed since I was able to re-install Django via pip twice now without the Disk quota error. That said, the reason I installed twice was because it disappeared again sometime in the last few days.

Thanks!


#16

Hi :slight_smile:

when we stop a project, we don’t store all the directories (to save backup space and to let projects start and stop quicker). One of the directories we don’t store is the .local directory, where pip stores the packages. So if you run pip manually in the console, you’ll always lose those files.

I suggest that you put the proper commands in the install step of your application, so that they will get installed again when necessary.


#17

Makes sense, good to know! I guess I was installing via the console while trying to gather info for the above mentioned disk quota issue… plus I’ve had some trouble with my install script running on every change despite careful “watch” and “ignore” rules, but that’s a separate concern :grin: Thanks for your reply!


#18

@wohclams Do you have an example Django project you could share? I see the flask one on your profile (https://glitch.com/~wow-python-flask) but wanted to compare how you’re setting up with Django. Thanks!


#19

Hey @etamponi. We just realized that our project lost all its files sometime in the last couple of weeks. It’s hard for me to pinpoint the day, but you have backups for led-zeppelin please help us get them back. Thanks!


#20

led-zeppelin restored :slight_smile: