Solution to mobile console issues

I did some research and discovered that you are using wetty and hterm for your terminal. I found a pull request implementing mobile device support. I then looked for the hterm repository, once I found it I looked around and discovered that the latest version contains official mobile support. I have built the latest version of hterm and it would be great if you could add it to the terminal. You can build it for yourself if you like using the above links, my version is located here. You can update hterm by moving the compiled file to ./public/wetty/hterm_all.js.


Do you guys have any feedback? @Gareth @jenn?

Thanks for looking into this. You’ll notice some of our staff in the thread in the PR too. Sadly, we’ve tried it out and it doesn’t work, but we’ll continue to look into ways around the issue with the console on mobile.

1 Like

That “solution” simply sets contenteditable to true, so you get keystrokes echo even when there should not be any, plus several other glitches in relation to page magnification and visibility of address bar. How did that bug manage to pass as “fix” is beyond me.

By the way, we are talking here about wetty 0.2.0 which uses hterm, but there is also wetty.js 1.0.3, more up to date fork which eventually replaced Google hterm with xterm.js.

I have not yet had a chance to see any xterm.js app running, and my first attempt to make it run on Android failed. So, let me ask you Gareth/Glitch Stuff, have you investigated this later, xterrm.js version of wetty, and if so why it was decided to stick with the old one?

1 Like

The person hosting wetty.js 1.0.3 (xterm.js)

…also hosts the last wetty (hterm) version before the project switched to xterm.js

I guess it’s worth looking into. I tried intall with yarn as per instructions and container ran out of space while adding the very last module. Cant remember what the problem was when installing latest (xterm) version through package.json.

If you use pnpm to install it, you probably won’t run out of space.