[solved]503 error and exit code 0 in 'Logs'


#1

Hi there.

I have searched for and read everything in this discourse about this error, and have tried all the tips and hints (small edit to package.json, wait 3 minutes etc…), but I can’t shake this error.

My app was running fine locally, but it’s unresponsive here.

My app is at https://cat-swoop.hyperdev.space


#2

You need to add the line "start": "node server.js", to your package.json to kick off your program. But other than a problem with some of your formatting in index.pug, and your URL verifying regex, it works - https://hyperdev.com/#!/project/love-stone


#3

Great @Gareth, thanks… That’s weird with what’s happening with the request.


#4

Yeah, I’m too dumb to be able to spot any issues in the regex, but if you think it’s fine and should be working, then I can find out whether it’s something we’re doing that’s causing the problem with it.


#5

@Gareth The regex was working fine locally, I have noticed something about the request to my api. I will open a different topic as it will diverge from the OP.