[SOLVED] Custom domain not working

#1

So using fly.io, I did everything and when I forward the DNS, it shows this error: “DNS not yet configured. Please review your settings or wait a little bit more.”
Project name: site-gaming-inc
Domain: gaminginc.tk

Can someone delete my custom domain?
#2

Hey @Infinity1231, this is one of the places where DNS configuration gets super confusing and it’s different for every DNS provider, which makes it even harder to talk about.

I think what’s happening here is that what you have shown is configuring DNS for site.gaminginc.tk, not gaminginc.tk, so the “Name” field is used to show the subdomain that you’re setting things up for. You can verify this by comparing the public DNS records for gaminginc.tk and the public DNS records for site.gaminginc.tk.

You might find https://glitch.com/help/custom-domain/ and the links there informative; particularly ther section about " My Domain Name Registrar Needs an IP Address" - since you’re trying to set a record for your “apex” domain (i.e. gaminginc.tk vs site.gaminginc.tk) you may need to use an A record with the IP address of your shw.io domain, instead of a CNAME.

1 Like
#3

How do I identify whether it’s for site.gaminginc.tk or gaminginc.tk

#4

I’m not sure what “it” is in that sentence, but in your DNS config, putting “SITE” in the Name field probably means that config is setting a value for site.gaminginc.tk (I say “probably” because different DNS providers do things so differently).

In many DNS provider configurations, “.” is a shorthand for the “apex” domain, but as the links in the article I linked to mention, because of how DNS works you can’t actually have a CNAME for an apex domain. Some DNS providers offer a workaround for that and do the IP address lookup internally; I don’t know if your provider does that - that’s a question for them. If not, though, and you want to use a Glitch Custom Domain for gaminginc.tk then you’ll need to use an IP address instead. You can find the IP address using the digwebinterface.com tool I linked to for your shw.io domain (or glitch.edgeapp.net, which works the same as your shw.io domain).

Hope this helps!

#5

Actually I had myself named it SITE because I didn’t know if had to make it gaminginc

#6

Ok I tried using the Glitch’s custom domain and in the “name” I typed www but it’s still not working :confused:

#7

OK! We’re getting there!

I see that DNS config in the DIG tool I linked to, so the DNS portion is correct. What’s missing now is that your project doesn’t have a Custom Domain set for www.gaminginc.tk (and so neither does fly.io). www.gaminginc.tk is different than gaminginc.tk as far as Glitch’s (and fly.io’s) configuration is concerned.

If you add that custom domain to your project everything should work with this configuration if you update that DNS record shown above to the new *.shw.io domain, but I would suggest using glitch.edgeapp.net instead - that works the same as all of the different shw.io domains.

#8

So you mean I should add www. to the link (on glitch custom domain) and instead of shw.io I use glitch.edgeapp.net

#9

Well, you can’t edit your existing Glitch Custom Domain, but you can add a new one for www.gaminginc.tk. With those two changes the configuration you have in place should work!

#10

Two changes? One is the glitch.edgeapp.net and second?
Edit: Nvm it’s www. Alright, I’ll try

#11

Oh!! It works!! Now, any way to add https://?

#12

https should work fine without any further changes - fly.io and Custom Domains supports it out of the box.

Unfortunately there’s no good way to force https using Glitch Custom Domains; if you want to do that you’d have to set up a fly.io app manually, as outlined in custom domain on fly.io.

#14

I want to set everything up from fly.io so please delete my custom domain www.gaminginc.tk
Project: site-gaming-inc

#15

That’s removed, @Infinity1231, sorry for the delay.

1 Like
#16

@cori

#17

I didn’t assume you also wanted that one removed, but it’s been removed now!

#18


I did everything but I get this error: not found: www.gaminginc.tk

#19

I see i wasn’t clear enough; my apologies.

If you’re using fly.io directly without using the Glitch Custom Domain feature then you should follow their directions, and their friendly support team can help with any difficulties you run into. The glitch.edgeapp.net destination only works for Glitch Custom Domains.

#20

Alright I’ll contact fly support then