[solved] Error express module not found!


#1

I already have express in my package.json but still getting this errror?


#2

This can happen if your project is full. If you’re seeing errors about that or changes aren’t taking effect, then you can free up some project space by running git prune and git gc from the command line.

If it’s not that, you can try removing the contents of the node_modules folder to force it to create it again and see the Express module:

rm -rf node_modules/* node_modules/.*
rm -rf node_modules
enable-pnpm

If you still have problems, DM me a join link so we can view the code. Thanks.


#3

i fixed it by using enable-npm !


#4

Great! But note that it now means node modules will count towards your project space.


#5

but pnpm not works???


#6

That’s not the case. Did you try following the steps I outlined above? If so and you’re still having problems, then DM me a join link so I can view the code as I offered.


#7

you already have link in DM!


#8

That join link is no longer valid.


#9

Sent a new link , didn’t know that link expire after some days!


#10

thank you for the fix


#11

The issue seems to have been caused by specifying github:hydrabolt/discord.js for discord.js as it was returning a 404.


#12

oh thanks didn’t know that!


#13

So you know anyway to install a github project as a module using pnpm?


#14

Like that, it’s just that user doesn’t exist anymore


#15

I fixed it myself ,now my project is on pnpm !


#16

It was transferred to https://github.com/discordjs/discord.js


#17

yeah i fixed it already btw thanks