[SOLVED] Error with an Sharex Uploader


#1

Hello,
I’ve been making discordbots with glitch
It works really well!
But
I made a uploader for sharex. - See here.
And it worked locally.
I wanted to use it with glitch but
it gave me this error.
Hastebin
It does not work if I use a folder or the assets folder with my project.


#2

PHP doesn’t work out of the box on Glitch like Node.js does. Have you remixed one of our example PHP projects or are you just trying to use a php file in a Node.js project?


#3

I am sorry for the slow reply. How can I run php in glitch?


#4

Remix from one of our PHP example projects https://glitch.com/~php-poc or https://glitch.com/~lamp-poc


#5

So the original issue “sharex uploader” has been fixed using lamp-poc
But an clone of https://github.com/deawx/QRCodeLogin-Server using lamp-poc does not work does throw this error

lamp-start.sh: line 3: .mysql/run-mysqld.sh: No such file or directory

lamp-start.sh: line 4: .apache2/run-apache2.sh: No such file or directory

How do I close this issue?
Also the project I used below wasnt applicable for what I wanted to do.


#6

@RazorApple if you still have questions or need some assistance can you clarify what you’re running into a little more?

On the other hand if you’re all set here then you don’t need to do anything more to close the issue.


#7

So I am having the error again

lamp-start.sh: line 3: .mysql/run-mysqld.sh: No such file or directory

lamp-start.sh: line 4: .apache2/run-apache2.sh: No such file or directory

I dont really know how to do this.
My other project (the sharex uploader)
works with lamp-poc
This does not.
I checked trought the files of sharex uploader.
They are the same.
How can I fix this?


#8

Did you start a new project? You’ll need to remix from your existing one or lamp-poc as those aren’t available out of the box.


#9

Thanks for the rocket-fast reply!

I did not. I copied it from an github rep

And can I please have the link to lamp-poc
and how can I make them available?
@Gareth


#10

Yeah, that will have the same issue - copying from GitHub will create a new project without the required stuff installed.

Here you go https://glitch.com/edit/#!/lamp-poc


#11

Thanks but I aleady found it by searching lamp-poc on google.
Cloning the project (the php app)
With the lamp poc stuff.
Ill report back when I fix this or an other error pops up

Also


#12


Can you help?

@Gareth

This has been happening with my other attempts at pushing to a glitch project. Please help. This is a huge problem.


#13

Hey @RazorApple, as the somewhat cryptic error message suggests, you can’t push directly to your Glitch project’s repo on the master branch, since the project itself it checked out on the master branch, and git won’t allow that. The positive side of that is that it indicates that you’ve got everything else configured properly.

What you need to do is in your local repo change to a new branch:

git checkout -b my-new-branch

Then you can push that branch to your Glitch project’s repo:

git push --set-upstream origin my-new-branch

Then in your Glitch project’s console you’ll use:

git merge my-new-branch

to merge your changes into your project’s master branch.

Let us know how that goes!


#14

Great! Thanks really much!

You should tell this to users who try to push.
Also check out my project I made using your help! thanks again!

https://daily-thursday.glitch.me/

I was at school if you were wondering where I was at.