[SOLVED] Files created in GitHub or the application console don't show up in the UI


#1

When I create new files in my GitHub repo and import it (not sure if it’s all files, but it’s happening right now with some webfonts), or when I create new files in the terminal (it’s happening right now with JavaScript files, so this isn’t just a webfont issue), they’re there, and they serve correctly, but they won’t show up in the left side file tree in the UI.

I checked the permissions on these files and they seem right:


#2

Hi mattstauffer,

right now, the editor only shows text files smaller than 500KB. I assume (but I am not sure) that webfonts are not text files, but even if they are, they’re probably larger than 500KB, so they don’t show up :slight_smile:

As for the files created in the console, we are still not synchronising changes made in the terminal with the editor. You have to force an editor “refresh”: just type the refresh command in the console. You’ll be disconnected for a moment, and then the new files will show up :slight_smile:


#3

Awesome, thank you! That did it for the made-in-console files. The fonts are all less than 500KB, but I’m guessing they’re not showing because they’re not text files.

Thanks so much!


#4

No problem :slight_smile:

Unrelated, but might be helpful: you might try our CDN for the webfonts, so that they’ll be delivered faster to your users. Just drag’n’drop them from your desktop on the Gomix editor, and they’ll show up in the “assets” view. Then you can copy the link we create for them and use it in your css/html/js .

Hope this helps too :slight_smile:


#5

Yah, great thinking–I was doing it this way partly because the reference to the font paths is in the (generated) CSS and I really didn’t want to fight with getting Gulp & and running at the moment. But once I do… that’s exactly the plan.

Thanks so much!


#6

You might find https://gomix.com/#!/project/assets-lib useful too - you can make the Gomix-hosted assets available from a relative URL.


#7

@Gareth YES! Thank you!