[SOLVED] Github Actions, Problems and errors

So I’m trying to add an action to my GitHub repository by using the regular .github.workflows/deploy.yml, yet every time I push to Github from glitch it deletes this file folder and the git action. I tried adding a folder named .github/workflows/deploy.yml, but if I try to push to GitHub then, it will simply say exporting to GitHub, and then simply disappear without an error message. Any Solutions?

1 Like

In case you are wondering the repository, it is here: GitHub Repo

Hi @KronosEternal! Sorry you’re having issues exporting your GitHub Actions, I’ve been able to replicate this and will flag it up to the team to see what we can do. In the meantime, I’ve found the workaround in this post worked for me:

Basically if you can add the .github/workflows yml file in your GitHub repo then import it into a new Glitch project it does seem to export successfully next time from Glitch (although it doesn’t show in the Glitch filetree) - not ideal but maybe gets you moving for now?

Thanks, I will definitely try this out, as I attempted previously to automatically merge branches but It didn’t work out, so I will see if this works for me!

2 Likes