Subdomain through Google Domains

Trying to have a subdomain from my Google Domain redirect to a Glitch app.

Followed the guide and followed this support post: Custom domain with Google Domains

When I navigate to the subdomain all I get is Not Found

This is from Google Domains:

First I tried the CNAME as coverhack with no A record but that failed. Trying with the A record (as suggested in the link above) also failed.

The custom domain:
The Glitch app:

Any idea where I’m messing up? I do have the main CNAME redirect to netlify, could that be messing things up?

That shouldn’t get in the way.

This sounds correct, what do you mean failed? Did you wait long enough (up to 48 hours)? The screenshot shows coverhack1 which doesn’t match the rest of your post.

In Glitch’s custom domain box, did you enter

The A record is supposed to be for the main domain, I’d suggest removing it or using it for the netlify host.

1 Like

Failed as in just returns Not found

Changed it to just this. It’s only been 16 hours, so going to wait a full 48 hours assuming this is all that needs to be done?

And yes it was set to in the custom domain box, but just checked it and it said domain already in use? Anyway I added the hyphen.

You can enter multiple domains / subdomains using the same box, already in use means it tried to add again, so that’s good.

I thought the hyphen was just in the project name, which isn’t relevant for DNS?

EDIT - maybe you now have two subdomains to the same project :slight_smile:

Added the hyphen assuming coverhack is now just locked in to something else. Is there a way to see it again?

Regardless, in 48 hours you think will show according to my set up?

As far as I know there’s no way to show it, likely its still pointing to the same project. For cleanup you can email glitch support to remove the unused one.

Yes it should do, good luck!

1 Like

@novatorem do you possibly have on google domains, NS records pointing at netlify nameservers? If so, you’d need to add the subdomain CNAME to netlify’s DNS instead of Google’s DNS.

1 Like

I do have my Name Servers pointing at netlify.

I removed them from google domains and set up from netlify. Is this what I should be doing?

Doing this it appears netlify simply redirects to the home page. Should I contact netlify or wait 48 hours?

It does this for subdomain coverhack this is from an A record. Note that it doesn’t for cover-hack. It takes longer to remove the records from the various servers than it does to add them.

Looks like cover-hack is now working, in time coverhack should also.

1 Like

Thanks for your help - I’ll change the solution since this appears to be the only search result for netlify custom subdomain.

1 Like