Superfetch install error

continuous failure ,

npm ERR! code ETARGET
npm ERR! notarget No matching version found for superfetch@^2.6.0
npm ERR! notarget In most cases you or one of your dependencies are requesting
npm ERR! notarget a package version that doesn’t exist.

npm ERR! A complete log of this run can be found in:
npm ERR! /tmp/npm-cache/8.15.1/_logs/2019-07-20T20_34_58_917Z-debug.log

Superfetch does not have a version 2.6.0, try installing version 1.1.1 as that is the latest version released to the public.

error in every way giving , not installing.