Support for Node v13 and v14

Node.js is great, but you know what would make it better? Having the ability to use Node v13 and Node v14, they bring us EcmaScript Modules, which are awesome, and many other features that you can’t get without v13 or v14.

Please allow us to use Node v13 and Node v14, prewritten code that use ESModules will completely break if pushed to Glitch, I think that v13 and v14 would be a good addition to Glitch.

I believe that there is a way to get node 13 on glitch, see this:

Interesting, it would be nice to have native support though.

1 Like

Yes. You have my vote, but someone ran away with them!

1 Like

runs off to find @TheBigC’s votes

6 Likes

I agree.

That being said, node 12.x supports ES modules with a flag, so you can use them by modifying some fields in your package.json:

{
  "type": "module",
  "scripts": {
    "start": "node --experimental-modules ./path/to/your/entrypoint/script.js"
  },
  "engines": {
    "node": "12.x"
  }
}

(or without the "type": "module" field, using .mjs extensions):

{
  "scripts": {
    "start": "node --experimental-modules ./path/to/your/entrypoint/script.mjs"
  },
  "engines": {
    "node": "12.x"
  }
}