Support forum SSL being weird

Today I noticed that the SSL status went from secure to unsecure. It says the certificate is valid, but I still get the pop-up. I wonder if it is a Discourse issue, or possibly a hosting issue?

2 Likes

I’ve noticed this as well. It’s definitely something that should be investigated.

1 Like

Yeah it is weird.

1 Like

I really do agree. I have a Discourse site of my own that is hosted on my VPS and I don’t have the issue.

2 Likes

(someone correct me if I’m wrong) Could it be those multi-year certs being blocked? Many browsers were blocking multi-year certs now.

1 Like

Actually, they got the certificate in July, and it expires in October. image

1 Like

Yeah, you are right. Lets encrypt only does certs for 3 months.

1 Like

I think Cloudflare uses Let’s Encrypt to make certificates. image

That is my certificate given by cloudflare.

happens when you visit this thread Private Projects won't private in the editor for example. it embeds a non-https video, which changes the page to be mixed content.

image

image

discourse does some stuff with javascript instead of full page reloads, so the security status then stays that way

But the thing is, it is on every page.

1 Like

Glitch Support needs a BugZilla type thing (or like bugs.discord.com) instead of the forum

2 Likes

1 Like

Discourse doesn’t use an image proxy (at least in a traditional sense) so people can use non-https images creating “mixed” content like @wh0 said.

If you ever see this error, you can always copy the link into a site like whynopadlock.com and see the mixed content.

This is happening to me as well!

This was briefly happening to me for one hour but is fixed now. :smiley:

Yup, that’s a good thing! What happened with the SSL

I already mentioned this before:

1 Like

That topic was made ages ago and was resolved, too.