Teachable Machine Model Integration Issue - Camera Not Showing

im pretty beginner on this and chatgpt is helping me to write the code so i let it describe the issue :slight_smile:

I’m facing an issue with integrating a Teachable Machine pose model into my HTML project on Glitch. When I initially used a URL to access the model, the camera worked correctly. However, I now need to use locally uploaded model files, and the camera is not showing up.

Details:

  1. Project Overview: I’m working on a web project where I’m using a Teachable Machine pose model to interact with a real-time camera feed.
  2. Issue Details: After switching from a model hosted on a remote server to using locally uploaded model files, the camera feed is no longer displaying. There are no error messages, but the camera simply does not appear.
  3. Relevant Code: I’ve included the relevant HTML and JavaScript code in my project. I’ve double-checked the file paths and everything appears to be in order.
  4. File Structure: All model files (model.json, metadata.json, and weights.bin) are in the same directory as my HTML file.
  5. Steps Taken: I’ve tried various troubleshooting steps, such as checking the file paths, ensuring that the files are correctly uploaded, and reloading the project, but the issue persists.
  6. Browser and Environment: I’m using Google Chrome for development on Glitch. The issue remains consistent across different browsers.
  7. Expected Outcome: I expect the camera feed to display as it did when using the remote model URL.

Reproducible Example: I’ve provided the HTML and JavaScript code in my project. You can access it here

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.