Terminal / Console Permissions Denied

“Download Project” pops up when I search for download, but I don’t know where the line is. Clicking on Download Project just downloads a tgz file

Oops! I meant to say rewind.

I rewinded the project to the time where it still worked, but it didn’t fix it

@17lwinn do you know a solution to this?

try


npm install --unsafe-perm=true --allow-root

or if that doesn’t work:


npm init

follow these steps to allow global installation:

How to install npm packages globally (guide)


hope this helps

The first command gave me the same error as above, and the second one didn’t help.
I’m currently following the guide, but have a question. Where is the .bashrc/.zshrc file?

the .bashrc is created by you. i reccomend .bash_profile if you want it read every session

try:

npm cache clean --force --unsafe-perm 

did this help @Crackhog?

After clearing the cache it still doesn’t work :frowning_face:

yikes, have you tried global install?

have you tried npx or pnpm?

I don’t know what that means

try pnpm install or npx install

pnpm install:
ERROR This “node_modules” folder was created using the --shamefully-flatten option. You must add this option, or else add the --force option to recreate the “node_modules” folder.

npx install:
install: missing file operand
Try ‘install --help’ for more information.

well, if these do not work then that will mean that you need to run chown- but that needs sudo, so i’ll ping @glitch_support for help

1 Like

you would run:

chown -R `whoami` ~/.npm
chown -R `whoami` /usr/local/lib/node_modules

sorry I could not help this time!

1 Like

You can also send support@glitch.com an email.

Just had a look around, it isn’t possible to chown without sudo

1 Like