Terminal: inserting in vim puts everything 2x


#1

I’m trying to use vim for some coding tasks.

Entering insert mode, typing some text, exiting; when exiting, the text is inserted again. So everything is duplicated.


#2

Hi @NoobDoesMC :slightly_smiling_face:

This does not happen to me, so perhaps you’re using the wrong commands to enter/exit insert mode.

This is what I type:

vim test.txt
i
Actual text I want to enter
<Esc>
:wq

i enters insert mode
Esc makes vim go back to normal mode
:wq in normal mode are two commands: w for write (save) and q for exit.


#3

Here’s what happens to me


#4

I can’t reproduce :frowning: I also tried the console in Safari.

What happens if you do the same steps on a local shell?


#5

it works fine in my terminal… is that what you mean?


#6

Then I am really not sure how to debug the issue… I can’t reproduce :frowning:


#7

So I hit Open Console from the advanced options within my editor, then type

vim test.txt<CR>
iText<ESC>

but see

TexTextt in the output


#8

I did exactly the same steps as you, and couldn’t reproduce. Can you try with Chrome and/or Firefox?