There is some unlisted user on my project that deletes stuff


#1

So i own a discord bot project and theres only 2 people including myself on it. Then randomly some 3rd person appears but he is not on the user list we know hes there because there is a random | on different lines, and deleting hard worked on code please help solve this. Also certain commands arent working anymore. Glitch has been doing some weird stuff lately and I do not like it at all.


#2

Now he is deleting node files by the console


#3

Hi @DeveloperNeb101 we’ll need to know your project name to be able to look into this at all. You can provide it here or email it to support@glitch.com if you’d prefer and we’ll take a closer look when we can. In the meantime, if you’re an admin on the project you can remove a user by clicking on their name in the editor and selecting “Remove from project”. I’m sorry for the bother with this issue!

From the perspective of the other problems, Glitch hasn’t made any changes that would effect how some Discord bot commands work, and we’ll need to know more than

to be able to investigate in any useful fashion.


#4

The project name is gladenation-bot. But the problem is I cannot remove the user because he is not part of the user list, but yet he still randomly shows up on the project.


#5

I took a quick look and didn’t see anything in the project rewind to indicate an unknown presence; can you give me some specifics of what changes have been made or what files have been deleted so I can look closer look later on?

As you’re probably aware, what you’re describing shouldn’t be possible - whether your project is public or private, only explicitly-invited project members (or people allowed to help from a help request) should be able to edit your project’s files or access its console. If there’s a problem of this nature, we’ll act quickly to resolve it.


#6

Here was one of the first things deleted that i replaced:

const Discord = require(‘discord.js’);
const Commando = require(‘discord.js-commando’);
const status = require("./resources/status.json");
const activity = require("./resources/activity.json");
const client = new Commando.Client();

Then later on the bot just would not respond to any commands, so I waited a few minutes and tried again then it worked.

But now in the logs we are getting this error that we never got before:

(node:22989) UnhandledPromiseRejectionWarning: DiscordAPIError: 404: Not Found

at item.request.gen.end (/rbd/pnpm-volume/ea312467-098c-43a9-991b-9978d5747180/node_modules/.registry.npmjs.org/discord.js/11.4.2/node_modules/discord.js/src/client/rest/RequestHandlers/Sequential.js:79:15)

at then (/rbd/pnpm-volume/ea312467-098c-43a9-991b-9978d5747180/node_modules/.registry.npmjs.org/snekfetch/3.6.4/node_modules/snekfetch/src/index.js:215:21)

at <anonymous>

at process._tickCallback (internal/process/next_tick.js:189:7)

(node:22989) UnhandledPromiseRejectionWarning: Unhandled promise rejection. This error originated either by throwing inside of an async function without a catch block, or by rejecting a promise which was not handled with .catch(). (rejection id: 2)

(node:22989) [DEP0018] DeprecationWarning: Unhandled promise rejections are deprecated. In the future, promise rejections that are not handled will terminate the Node.js process with a non-zero exit code.


#7

I believe you also mentioned files being deleted? Do you have an example of that?

As far as the other problem, on the surface that looks to me like snekfetch is trying to retrieve a file from a url that doesn’t exist, but I haven’t looked closely. You also might consider replacing snekfetch (which has been deprecated) with node-fetch.


#8

Yes some code was deleted in index.js I gave the cosnt example above. Also how do you switch node-fetch?


#9

ive gotten the smae problem on my project but it didnt mess with anything and went away after a while. like this it was not listed and did move once from its location