Trouble leaving a project

@glitch_support I joined a project to help someone who “Asked for Help” (project name: esoperoject-1) – but after I was done, and I clicked the “Leave this Project” button, I received an error message in a red pop-up

image

Refreshing the page, or trying to leave the project again a few minutes later, didn’t help (or work).

Hi @tdanford,

Thanks for letting us know! I’m sorry that you couldn’t leave a project!

I just tried to replicate this and was able to leave a project I joined via Ask For Help without error.

I also see that you are no longer a member of that project you were helping with. Were you eventually able to use the Leave The Project button?

Also, can you tell me what browser you were using when you received the error? (I tried in Google Chrome)

For the record, I was using Chrome – and I’d tried several times over the course of a day or two.

But in between my last update to this message and your message, the issue appears to have been resolved? The remove-me-from-this-project seems to have completed without additional interaction on my part, and I don’t see the project in my list.

So I guess it’s resolved now? At any rate, the only error I could record was the one I took a screenshot of, above.

Thanks for your help!

Thanks for letting us know! If this does start happening to you again, please post here so we can take another look!

Hello,
I have the same problem: could not “Leave the project”. I clicked the “Leave this Project” button and received an error message in a red pop-up. That’s project https://glitch.com/~bot-about-you
Please help.

Regards,
Nikolay

Thanks for your report @NikolaySuslov . I’m sorry that you can’t leave the project!

From what page are you trying to use the Leave Project button? From within the project editor? From the project page? Or from your Profile Page?

I was trying to leave the project from the project page and profile without success. But, now I see, that I left that project.
Thanks for your help!

Best regards,
Nikolay

@tasha I’m also having the same problem when I try to leave a project from the home screen or my profile. When trying to leave a project from the project page, it doesn’t appear that clicking the Leave Project button actually does anything (besides fire off a sentry.io request).

The “Something went wrong” message is the result of this network request:

Request URL:https://api.glitch.com/v1/projects/[UUID]/users/[User Number]
Request Method:DELETE
Remote Address:107.23.149.33:443
Status Code: 403 Forbidden

Response: {"message":"Not authorized to modify project","code":"Unauthorized"}

Project link: https://glitch.com/~satin-ladybug-yjh10xoab

Hi @noelleleigh! This is a bug on the homepage side that I have the team looking at. In the meantime, you should be able to leave the project from the editor view.

From the editor’s perspective, it doesn’t look like I have joined the project? Not sure what I should be seeing here.

Ah this is another bug that I’ve let the dev tools team know about!

1 Like