Trouble with the Console

#1

I’m trying to host a Minecraft server with Glitch, to see how well it works. I tried using the console and apparently the sudo command is not found. How can I get around this?

0 Likes

#2

Hello @levistep32,

What command are you trying to run with sudo? Have you tried using it without sudo at the beginning?

0 Likes

#3

For my Minecraft server, I’m using NukkitX, which is Java-based. I checked the version of Java, and it says it’s OpenJDK version 1.8. I’m trying to install a newer version of Java, with the command sudo apt-get install openjdk-8-jre.
When I try without sudo, it says this:

E: Could not open lock file /var/lib/dpkg/lock - open (13: Permission denied)
E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?

The server works fine with version 1.8, but I think it would run better with version 8. It’s not absolutely necessary that I do this, but it would probably also be helpful in the future to know this.

0 Likes

#4

Hey @levistep32, unfortunately you won’t have access to sudo inside the Glitch container, so you won’t be able to update Java. Sorry for the bother!

You could take a moment to vote for Java outdated (UPDATE), and the next time we update the container software we might include a java update. However I don’t have a timeline on when we’ll be updating the container right now.

1 Like

#5

Thank you for the help!

2 Likes