Unable to access *.glitch.me websites

I’m adding what have written to me a friend of mine:

The problems seems related on how glitch distributes the DNS records worldwide (maybe an AWS route 53 geolocation misconfiguration??) . So to reproduce the problem you have to query an italian DNS server: # dig http://demo.glitch.me @

; <<>> DiG 9.8.2rc1-RedHat-9.8.2-0.68.rc1.el6_10.3 <<>> http://demo.glitch.me @
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: REFUSED, id: 511
;; flags: qr rd; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0
;; WARNING: recursion requested but not available

;http://demo.glitch.me. IN A

;; Query time: 10 msec
;; WHEN: Tue Dec 3 17:49:20 2019
;; MSG SIZE rcvd: 32

I have the same problem with FASTWEB internet provider,
I solved by changing the DSN to


1 Like

@masozzo I have changed the DNS too, but nothing changes.

My ISP is another one, Vodafone. Then it could be some problem in glitch location configuration

@aborruso Be careful to put as the primary DNS

@masozzo I know, thank you, I have tried with 8888 and 8844.

It doesn’t work.

@aborruso Try using it worked for a lot of people who had the same issue.

I have tried also with 1111, but it’s the same. Thank you.

Moreover I think it’s necessary not a solution for me, because my goal is not to study and test glitch, but to build an app that other people can use. Do I must ask to potential final user to change DNS, or use tor or VPN connection?

I’m not a network or a sysadmin expert, but I think that glitch stuff should check something.
Because here in Italy there is the same problem with different ISPs, because I’m able to connect using tor connection, and for the kind of reply we have querying from an Italian DNS server.

Hi All!

Since there has been a lot of activity in this thread lately, I wanted to chime in.

Our team is aware of this issue and this forum thread. We will be taking a closer look at this in the future. However, I can’t give you a firm date for when the work will be done. We understand this is very frustrating for those of you who are experiencing this right now. Thank you for your patience!


And thank you for you time!

Thank you for you time, writing just to notify that I’m still experiencing the issue. Writing from Italy.

I’m on a company laptop and can’t change my DNS


welcome @esnho ! Yeah i am having same issues here, its your internet provider probably. I asked for support some time ago about this and they told me that *.glitch.me domains cannot be reached due to my isp blocking the website…

So Vodafone Italy blocks glitch.me !?

:frowning: :frowning:

It seems that it’s not a problem only related to the internet provider. There are a lot of problems in Italy with different providers.

Moreover I’m able to connect to glitch via tor browser and it seems that there could be problems related to some glitch DNS configuration.

I would prefer using a vpn to connect to glitch, everytime i need to test my webpage im forced to use a vpn to load the project’s .glitch.me domain

is there any solution to this issue for vodafone italy? it makes glitch.me unusable…

Change the DNS to or

You can get some more information on changing DNS servers here:

Try this https://github.com/benborgers/glitch-proxy
and/or https://proxychief.glitch.me/

1 Like

XD the second one won’t work. But good tip.

To fix it for your site visitors, you can proxy with cloudflare, which covers both the DNS problem and also translates IPv6 to IPv4.

Example setup …

1 Like