Unable to create new project by cloning repository

I just tried to create a new glitch project by cloning a GitHub repository, and it just sits there on the “Loading Project” screen. I’ve tried several times and each time it just hangs.

The repo I’m trying to clone is https://github.com/googlecodelabs/your-first-pwapp.git.


hi pete! sorry you’re having trouble with this - i just had the same issue trying, so i’ve asked the team to take a look at why this particular git url import is failing.

in the meantime, if you create a new project with either of the other options, you can then import the googlecodelabs/your-first-pwapp repo in the editor and that should work: within the editor, on the lower right corner you’ll see a “Tools” button. in that menu, select “Git, Import, Export” and from there you should be able to import this repo.

Thanks Jenn. I’ve had other reports of this on our Git repo, and have added your suggestion there. This is part Progressive Web Apps: Going Offline  |  Google for Developers.

Hopefully it’s an easy fix.

Can you try Cloning the repo in a different web browser
because it sometimes happens to me when i try to clone a github rep on Google Chrome
and when i switch to IE 10 it works.

Hey @petele I just wanted to follow up here - we’ve discovered a bug in project naming that appears only to be affecting this repo (right now) and only when cloned, not when imported as Jenn noted.

I’m not sure when we’ll have a fix ready, but I’m hopeful it will be soon.

Sorry for the bother!

A post was split to a new topic: Problems exporting to GitHub

Hey @petele just a quick note, we released a fix for this bug today! If you or your users are still encountering problems, please let us know!

FWIW, I was still running into this problem today. Creating an empty project then importing into it was still a valid workaround.