Unable to import from GitHub unless I sign in and grant GitHub access to my account


#1

The GitHub Import Button app says that no account is required to import code from GitHub. However if I try to import code from GitHub either without a Glitch account or with a Glitch account that hasn’t been granted access to repos on GitHub, then the import page just hangs on “Fetching project …”.

Am I doing something wrong or is the import broken? This feature isn’t useful to me unless people can import/remix without creating a Glitch account and granting it access to GitHub.

I’ve tried it both in Chrome and Firefox. I even tried disabling AdBlock. Didn’t work.


#2

My usecase is that I’m creating a sample app. I’d like for developers to have the “Remix on Glitch” button so that they can easily have their own version of the sample app running without needing to install a bunch of stuff locally.

I could just link to an existing Glitch project and tell them to remix it but using the GitHub import has the added advantage of always being up to date. I could manually update the Glitch app but I’d much prefer to just keep the GitHub project updated.


#3

It looks like you’re missing the github part of the import URL. It should be:
(http://glitch.com/edit/#!/import/github/york-solutions/fs-sample-app)

That one just worked for me. You’ll see it remix the welcome project, and then disconnect for a second to reload the project after the import.


#4

Thanks! Looks like the instructions on the Generate GitHub Import Button app are incorrect.


#5

We’ve fixed them up - sorry for the hassle.