Unable to import from github

Im trying to create a project from https://github.com/EternalFrostOrig/arrasio, however, when ever I try to do this it fails and tells me something went wrong and to try again.

Is there something wrong with this repository, or is this feature not working 100%?

And is there any way to see what went wrong? I feel like that would be more useful than just “Try again later”

Perhaps try again, it imports without issue the few times I’ve tried.

I keep trying at different times and it doesn’t work, do I need to make an empty project somehow?

No, it overwrites the contents of the current project in the editor. Do you see any errors in your browser console? Also, try via this link: https://glitch.com/edit/#!/import/github/EternalFrostOrig/arrasio

The link worked thx

Console output when import fails:

It looks like you were putting the full URL to the GitHub repo into the input box. It requests just the user and repo name. We should add some validation to the input provided.