Unable to install Lavalink

#1

Hello. I was coding a bot, and I tried to install lavalink. I’ve uploaded the Lavalink.jar file to my directory:


And when I tryed to install it with java -jar Lavalink.jar, it shows me this:screenshot2
I’ve already saw this article: I cannot install Lavalink, but still not working.
What’s happening?

0 Likes

#2

Hi TheBigerGamer, what browser are you on? Sometimes in Safari there is a bug where files go to assets when they shouldn’t. Assets is for images, audio files, and other similar file types. I’d try uploading the jar file in Firefox or Chrome. If that doesn’t work (or you already did that) let me know.

0 Likes

#3

I’m in Google Chrome. But the Lavalink.jar file is in the assets.

0 Likes

#4

Ok, so click on it in assets and you should see a link. On the command line you can get it into the file system using that link by running:
curl -o Lavalink.jar URL
The url will look something like https://cdn.glitch.com/82c06eac-c3a6-4bb0-ac1d-355c90bf10b5%2Flavalink.jar

I think the issue you might run into though is in that linked thread where they said lavalink might not work with our version of Java.

2 Likes

#5

It worked. Thank for your help.

1 Like