Unable to rename a remixed project

Hello guys,

So I just joined Glitch and decide to remix an interesting Tensorflow.js project. However, when I try to change the name of the remixed project, I keep getting the error ‘updating this project is not allowed’. I’ve even tried remixing a basic Glitch web app project and got the same story. Am I doing something wrong?

When I go to the project page to rename it, sometimes it says ‘Something went wrong. Try refreshing’ and the other times, the page reloads and then informs me there is no project with the updated name.

1 Like

Hi @PeculiarE and welcome to Glitch!

I’m sorry that you are seeing that error when you try to update the project name. Thanks for providing the screenshot showing this.

I just tried renaming the project and was able to. I reset it back to the original remix name after doing this. Can you please try closing out the tab and then opening the project in a new browser tab and see if you can update the project name now? If you cannot, let us know.

1 Like

Hello @tasha , thanks for responding. So yeah, I just tried renaming that same exact project on the edit page (just like in the screenshot I sent) and this time around, it worked. Thank you.

But then I decided to rename all my projects and things got a bit wonky. Some projects let me rename them on the edit page. Others still threw the ‘Updating is not allowed error.’ I then tried going to the project page to do the renaming and then it worked for those. Quite surprising.

But even more worrisome, what’s the fact that none of these methods worked on my Chrome browser. All my updates (both on the edit page and the project page) only worked on Safari, even though one method would work and the other wouldn’t, but at least the project got updated in the end.

I couldn’t do same in Chrome. Even cleared my cache and all that and still got the same errors. Guess I’d have to use Glitch with Safari for now.

Hi @PeculiarE thanks for those additional details! Glitch should definitely work in Google Chrome.

Here is what I advise doing:

  1. make sure that Chrome is allowing cookies to be saved for glitch.com and glitch.me
  2. try turning off any Chrome extensions/add-ons to see if the problem goes away

If you check these two things in Chrome and still see the issue, let us know and we can continue troubleshooting.

1 Like