Unable to rename project?

I wanted to change my project name but whenever I enter a new name (Not a single damn chance anyone used this name before since its random smashing on a keyboard) it says its already been taken.

What in the world is this?

Thats odd, could you clear your cache or reload (or do both by press CRTL+F5)?

Just tried that, didnt help at all…

What browser are you using?

The new Microsoft Edge (Based on chromium)

Glitch should (in theory) work fine there. You might want to contact support@glitch.com.

But just as one more test, could you open the command prompt and run:

curl -I https://api.glitch.com

I’ve been using Edge for half a year now without problems on glitch and the api is fine on my end according to curl so im clueless

Also this is what i mean, No way does anyone have some random letters as their name in the exact order i just did…

Can you try going to the project page and renaming your project that way?

Yes that worked, Thank you so much.

Still makes me wonder why it doesnt work from inside the project though. :confused:

Yeah, I had the same issue yesterday. I went to the project page and it worked.

Lets just hope some staff member sees this and try to fix it :slight_smile:

^^^^^^^^^^ Staff don’t often respond to threads here.

That should be SHIFT+F5

Hi there - are you the owner of the project or are you just a member? If you’re the owner, can you email support@glitch.com with the name of the project and the name that you want to change it to so we can look.

I’ve already filed a ticket about members having an editable field but not being able to edit the project name in the editor when they’re not the owner.

Hi there, Yes I am the project owner and I’ve managed to change it on https://glitch.com/~myprojectname and that worked thanks to someones suggestion. It seems to apply to owners too that it says the name is taken while I am pretty sure it wasnt.

Can you email support with the name you wanted to change it to? I cannot replicate the bug for an owner so I wonder if it has to do with the name you’re trying. It could be using a reserve word, for example.

I actually mashed my keyboard a few times as you can see in the small clip I posted earlier, completely random letters didnt work in all sorts of combinations. It can’t possibly be that every single character I entered has been used in a name before in that exact order. Seems unlikely.

1 Like