"Upgrade Required" instead of my webpage, code not loading and node installing at every startup

javascript

#1

I’ve already created a post about not being able to connect to my node server, but this is touching the actual problem, I guess.
What is going on is that after I deleted index.html, client.js, README.md and my custom script.js file, instead of the website that should just normally say nothing (no index.html should equal to just a blank site), I’m getting “Upgrade Required” text. A user named callumok2004 tried to help me in my previous post, and then tried to take a look at my code, rewrite it a little. He was literally like “where the hell does this come from?!” Then he went offline or did something else, I don’t know. I noticed that the code didn’t want to load at all, but that’s not because he changed the code in a bad way. After i commented out all of his added code, nothing changed. I needed to rewind the code to be able to start the website.
After that, I noticed very old version of node installed, because 6.x version. Since there is already 11.x available, I’ve changed it to 11.x. And here we have another problem - node version 11.x is installing now everytime the website reloads. The installation isn’t looking like a module one, so here are the logs:

node v11.6.0, with pnpm

8:15 PM

Installing…

8:15 PM

Performing headless installation

8:15 PM

8:15 PM

Total install time: 3142ms

So sumarizing: I have “Upgrade Required” text instead of my website after deleted a couple of files. Rewinding doesn’t help at all, writing another index.html file doesn’t help too. Deleting it competely results in the same. I also had a problem with not being able to launch my website, for whatever reason it was, because the code looked competely right and only rewinding (not deleting it) helped. Another problem is node installing at every launch-up, after i changed his version from 6.x to 11.x. The problem is vanished when I change it back to 6.x. Here are the logs:

node v6.16.0, with pnpm

8:29 PM

Installing…

8:29 PM

Previous installation was done with Node v11, recreating node_modules

8:29 PM

Performing headless installation

8:30 PM

Resolving: total 1, reused 0, downloaded 0

8:30 PM

Resolving: total 1, reused 0, downloaded 0

8:30 PM

Packages: +2

8:30 PM

++

8:30 PM

Resolving: total 2, reused 2, downloaded 0, done

8:30 PM

8:30 PM

dependencies:

8:30 PM

  • ws 6.1.4

8:30 PM

8:30 PM

Total install time: 4458ms

I really hope someone will help me for real now. There problems seem to come literally out of nowhere. Anyway, I think it might be caused by a hidden file that can’t be normally edited, thus editing visible ones doesn’t help. Only rewind option can get it’s state back. Just an idea.
You can view the code and eventually edit it here. If I haven’t provided enough information, please write.


#2

Hey @supahero if you take a look at my post on your other thread that might shed some light on what’s going on here. My apologies about that - I mistakenly placed it on the wrong topic.


#3

I decided to use other framework, but thanks for that. Now the problem has dissapeared, but I’ve got another one, that showed up for a while before. My website can’t start up for some reason. It’s infinitely starting without any messages or logs. Also, should I use node version 6.x? Because version 11.x is really installing everytime the code is refreshed. Quite annoying.
Let me close this after I will get an answer for these.


#4

I wouldn’t use Node 6; among other reasons, it won’t solve this problem. The sort of behavior you’re describing typically means that your project isn’t listening to one of the ports Glitch looks for, and Glitch will keep restarting your project until it sees it listening somewhere.

One easy way of doing that is described in this sample express config. It looks like you’ve moved or deleted your project so we can’t take a close look to give specific advice, but if you want to tell us the new project name we can try to help out.


#5

I had this issue. You maybe use WS. To make ws work with express you must use express-ws


#6

@supahero you have the ws loaded, but it is waiting for a request, @cori has mentioned about this to you previously, so maybe take a look at the message he said about it!


#7

The problems are gone now. Thank you for your help.