VS Code extension - unable to open any of my projects

When I try to use the VS Code extension, I go through the login process, then choose the “Glitch: Open Project” option to open a project from my account. I select the project, and the new window appears with one folder in the file sidebar… which disappears after a couple of seconds.

The following text is then displayed in the status bar: “Extension ‘Glitch’ removed one folder from the workspace.” And now I have a VS Code workspace window with no files in it, and that’s it.

Looking in the Problems window, I find:

settings.json ~/Library/Application Support/Coe/User
Incorrect type: Expected ‘string’. [80, 19]

Looking in settings.json, the problem is this line:

  "glitch.token": null

If I remove that line, it just gets added again if I retry. I don’t know what this setting is meant to be set to.

There’s no other information that I can find as to what’s going on. Anyone have any ideas?

Which OS are you running in, eg. Linux, Windows, OSX?

The glitch extension is trying to store your authentication token in there, null would presumably mean the login didn’t work? Did it prompt you for a code sent by email, or to login via some other method?

I’m running Manjaro linux, so my settings.json is in a different path to yours. Mine looks like

    "glitch.token": "xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx"

The value of the token is a different string, but the same format as, the Glitch project token, so if you can’t get the login to work, it might be worth trying to manually put that token in.

From the glitch edit project page Tools > Git, Import and Export > Write > Copy User Name.

I finally got this working. The problem was that nothing anywhere told me I needed a token, or where to get it from. I had to figure that out myself, which took a while. :slight_smile: