Weird json format

Hi everyone I’m new here in glitch and i gotta say that i love the site and the concept and everything here but i have a problem.

when i try to read a json file from python the json file end up beign like this:

{u'name': u'rick7pwd=yolo', u'auth': u'yolo', u'f': u'a.json'}

i have been reading and i read that the prefix u’…’ is the way python tell you that the text is unicode or something like that but when i run the exact same code in my machine everything works fine

can anyone help me here i really would apreciated

@richardjimenezyolo, welcome to Glitch, and I’m moving this topic to #coding-help so that more people will be able to help you!

1 Like

you know what i figured out the problem.

it was because glitch run python 2.7 by default so i had to install flask and gunicorn with pip3 and now everything is working fine,sort of, now my page is taking too long to load and i don’t know if it is because my internet connection is slow or glitch is punishing for deleting and re-creating the project and the acount several times while figuring out the problem.

thanks btw.

1 Like


You can use a JSON beautifier.

I already solved. The problem was that glitch by default user python 2.7 and the json lib in python 2.7 load the json as unicode.

but thanks anyway

1 Like