Weird problem with glitch hanging on remix


This morning, I was working with a group of students in a class I’m teaching. At one point (~9am) two of the students started having issues where if they tried to remix any project, right after the “new” project appeared by while it was still loading, glitch would display the “you’ve lost connection with the server, …” message in red in the upper left of the screen.

Other students in the class (and me) had no such problem. We tried different browsers, different computers, etc. Their accounts now became unable to remix. The old projects in their accounts were accessible, but not consistently.

Eventually, I sat with them and deleted all the projects that got created after the first failure (they tried a few times, as we moved between machines and browsers, tried resetting the network, tried logging in and out). After all of those projects were gone, things started working again.

I have no idea what or why this happened, and it only affected a few folks, but it chewed up a ton of class time trying to figure it out.

Was there something that happened this morning? Or is there a problem where a corrupted project of some form can take down an account (i.e., some backend database is scanning through their projects when they remix, and a bad one causes something to fail?)

Any guidance on what to do if this happens again?


Hi blair :slight_smile:

We were aware of the issue, and we just finished working on it. The fix has just finished deploying :slight_smile: Sorry for the inconvenience… Let us know if the problem keeps happening!


I’ll be sure to let you know if it happens again! Thanks.