What is the latest supported Node.js version?

How do I know what is the latest support Node.js or npm version on Glitch?

You can see a list of all supported Node versions at the link below. Currently the latest supported Node version is v16.12.

https://nodeversions.glitch.me

The npm version used will be the one that was shipped with the version of Node you choose to use, except for Node v16.12. That version was shipped with npm v8.1, but for some reason Glitch downgraded it to v7.20.6 some time ago.
If you want to look up what npm version is shipped with each Node version, you can see it on the Node website: