When project wakes up now


#1

I have this project that is triggered out of Facebook Messenger. Lately when the project is fired off the first time it doesn’t send the JSON back the first time. Has something changed where now it’s taking longer to wake up?

I haven’t tested it - I will have to wait until tomorrow to test unless you can tell me how long before the project totally shuts down so I can test it from Messenger. I think what might be happening is the request is timing out on the first run since it has to wait so long for the project to load now. Once I test it I can verify this.

So how ling until the project is TOTALLY down like if i waited a day. Because i can;t have this happening.


#2

Your theory sounds likely. The project startup time isn’t a fixed thing, but we’ve had a couple of server issues yesterday and today which might have contributed to a slower start time. If it’s a persistent problem you could look into keeping your project awake by adding a route for http requests and using a third-party service like uptime robot.

Projects sleep after 5 minutes of inactivity. Be sure to not have your project open in the editor while waiting for this as that keeps the project awake.


#3

Thanks Gareth that makes sense because it has been in the past few days that I am seeing that. Will the server issues be fixed soon?

and thanks for the heads up on having the project open when expecting it to sleeping. I will test that and see. plus for the recommendation on way to keep it awake. not sure if i will need that once servers are back up running normal


#4

Yes, we’re working on it!


#5

Thanks! Just FYI having big issues - took - Total install time: 14391ms just now - to install small project. Timeed out on the Messenger side and failed to deliver the response because Messenger disconnected the request. Thanks for working on !


#6

Are things fixed yet on this projects waking up? I had one that was for sleep for a week. It took over 6 secs to get started. Is this going to be the normal now? Just asking since I will have to look at other ways to keep this up because my messenger bots are getting no message on first attempt since I have 10 secs to get a response back to Messenger. 6%20secs'

I will be using uptime robot to keep this one awake


#7

https://support.glitch.com/t/resolved-reinstall-on-wakeup-resolving-takes-long-time


#8

so you used “enable-npm” - why not uptime robot the will request every 5 mins to keep it awake?


#9

Uptime Robot works great thanks for the recommendation. On the slow one its working great so far.


#10

No, this isn’t going to be the new normal. We shipped some improvements yesterday, which should halve wake times in most cases and we’re working on further improvements which will be released soon. Sadly, some things take longer than a few days to implement. I hope the keep-alive workaround is sufficient for your needs for now.