Why this keep happening? No repository

This is like the fourth time that happens, my bot stops running suddenly and, when I try to update packages, this error pups up:

npm WARN tk-game-bot@1.1.5 No repository field.

I haven’t changed the repository (Don’t even know how) and the only fix I find is remixing the whole project, and then, will work again!

That’s usually normal when installing npm modules

I had to remix my project, is bothering having to do it, so there is no fix?

Its just a warning, nothing very important

It is, I can’t start my project, just remixing worked.

Can you send your package.json file

  "name": "tk-game-bot",
  "version": "1.1.5",
  "description": "The Kidnapper Game Bot",
  "main": "server.js",
  "scripts": {
    "test": "echo \"Error: no test specified\" && exit 1",
    "start": "node server.js"
  "engines": {
    "node": "12.x"
  "keywords": [],
  "author": "Aylan Miranda (AylanJ123#9253)",
  "license": "MIT",
  "dependencies": {
    "discord.js": "^12.2.0",
    "np": "^6.3.2",
    "quick.db": "^7.1.1"

Try adding a repository field linking to whatever site to the file

How, and why my previous remixes worked without that?


1 Like

Also keep note that projects stop after 5 minutes of inactivity