`create-react-app` project never leaves "Starting" state


I have a project created from the create-react-app boilerplate. The package.json defines the start script, and logs show the development server starting:

ℹ 「wds」: Project is running at
ℹ 「wds」: webpack output is served from 
ℹ 「wds」: Content not from webpack is served from /app/public
ℹ 「wds」: 404s will fallback to /
Starting the development server...

However, the development server never finishes startup, the above output cycles every few seconds, and my app CPU gets in the Warn range.

The client keeps receiving

Node 10

Given the output it looks like it may be using webpack to build rather than react-scripts?

1 Like



Thanks for the reply! Good to know.
I’m receiving output from the server, so I believe a container’s been allocated and it’s running my code, just not the correct command for my project.

if i manually start the project using react-scripts start it works, but it looks like the process started by the watcher (15147 ? SN 0:00 /bin/sh /app/node_modules/.bin/react-scripts start) is failing every few seconds

@glitch_support I have the same issue still, where the project I created with “create-react-app” never leaves “starting state” and I see the exact same things as the OP in my logs.

How can I fix it?

1 Like

@glitch_support I’ve come across the exact same issue

@glitch_support I have the same issue. Any solution yet?

1 Like

It’s because react-scripts start not working without tty (stdin). I found a workaround by running react-scripts with concurrently (there is nice manual: https://dev.to/glitch/create-react-app-and-express-together-on-glitch-28gi)

1 Like

For anyone still dealing with this issue, I came to the same conclusion as @drakmail; it seems as though it has to do with how CRA / react-scripts relies on TTY, and my guess is that the Glitch docker image is configured without it.

However, I found an easy solution that does not require proxies, extra dependencies, and overall needs very little modification. Just run react-scripts in CI mode with CI=true react-scripts start; react-scripts does not need TTY in CI mode.

I’ve written up a full post on this solution, as well as how it can be improved to work across all OSes and only turn on CI mode on Glitch.


Thank you very much! works for me.