Error: Could not locate the bindings file


#1

Hello I found this error appearing in my console today and I don’t know what is its cause. Can someone help me.
https://ghostbin.com/paste/677e2
I was told that if I use enable-pnpm it would solve it and when I did do that it did solve it but my question here really is what causes it and what command can I run instead of enable-pnpm if I got this error outside of glitch.

Thank You
Deniernal354


#2

I’ve heard updating Node usually fixes this.


#3

I’ve got same issue, too. enable-pnpm however wouldn’t work for me Anyone have same issue?

Edit:Just upgraded my node, works now


#4

I’m getting the same error, already tried update node but no results… I can dm a join link if necessary.


#5

Sure, let me have it!


#6

Done :slightly_smiling_face:


#7

Looks like it’s back working already.


#9

I’ve got the same problem, should I just dm the join link?


#10

Hello, @xXForEverFasterXx, welcome to the Glitch Forums!

We’ve seen problems with the better-sqlite3 package before, and typically running enable-pnpm in the console (which forces a §npm install) fixes the issue.

If that doesn’t work you can just provide your project domain and we can take a closer look.


Error: Could not locate the bindings file. Tried: Please help!
I need Your Help better-sqlite3
#11

@cori enable-pnpm didn’t solve it. Should I just dm you the join link?


#12

Just posting the project’s domain (or emailing it to support@glitch.com) will be sufficient, thanks!


#13

The projects domain is nebulous-blizzard


#14

Hey my error still persists but not on better-sqlite3 it is on Node-Opus. I have tried npm install and my node is on the latest version so now I don’t know what to do.

Error:
https://hastebin.com/olixucotuk.sql


#15

Run enable-pnpm, or outside of Glitch try changing the version of node you’re using.


#16

Which version of node would you recommend?


#17

I think what Gareth means is that outside of Glitch (and within Glitch as well, for that matter), changing your Node version to something different will force a reinstall of your packages and fix the binding problem. enable-pnpm inside Glitch also has this effect, but that command is only available from a Glitch console. So just modifying your Node version (even just changing it, running ( p )npm install, and then changing it back may (should) fix the problem.