Cannot find modüle discord.js

ERROR EACCES: permission denied, open ‘/rbd/pnpm-volume/e267f9a8-775a-41c4-876c-7855d9839eb0/node_modules/discord-anti-spam-tr/package.json’

note: I deleted discord.js and installed it again

Can you run git prune && git gc then reinstall?

I tried, nothing changed

about 7 am CST this morning the same thing started happening to me

Have you tried the following commands-

rm shrinkwrap.yaml
enable-pnpm

?

@R4356th Dediğini yaptım ve bunu yazıyor artık “Invalid Form Body”

I also suddenly had a “cannot find module ___” error on one of my servers today. I fixed it by running npm install to reinstall all the modules.

Could you please copy and paste the full error?

Translation by Google Translate-
Lütfen tüm hatayı kopyalayıp yapıştırır mısınız?

Error: Cannot find module ‘on-finished’

8:29 PM

at Function.Module._resolveFilename (module.js:548:15)

8:29 PM

at Function.Module._load (module.js:475:25)

8:29 PM

at Module.require (module.js:597:17)

8:29 PM

at require (internal/module.js:11:18)

8:29 PM

at Object. (/rbd/pnpm-volume/e267f9a8-775a-41c4-876c-7855d9839eb0/node_modules/.registry.npmjs.org/finalhandler/1.1.2/node_modules/finalhandler/index.js:17:18)

8:29 PM

at Module._compile (module.js:653:30)

8:29 PM

at Object.Module._extensions…js (module.js:664:10)

8:29 PM

at Module.load (module.js:566:32)

8:29 PM

at tryModuleLoad (module.js:506:12)

8:29 PM

at Function.Module._load (module.js:498:3)

8:29 PM

Note: on-finished installed
@R4356th

Can you try running:

pnpm install discord.js

because npm hasn’t been working for me on glitch either

Strange. It is perfectly working for me.

2 Likes

Yeah, it refused to work on some projects and worked fine on others.

1 Like

Why do these kinds of things happen to me :frowning:

2 Likes