Can't import my github project

I’ve tried to upload my github project many times now, and I get same error every time.
“Arg, something went wrong. Try again? :@”
I’ve putted in (my github name/rep name) and it doesn’t works.

^That isn’t my real repository of course, but I’ve putted in my real one in the Github import field.

Hey @lillishaj can you share the repo you are using so someone can take a look? There are some things in a remote repo that can cause problems for the import.

mm?
does anyone knows a solution for this?

Try creating project from a GitHub repository or try to create just a new fresh project and import code to it.

Doesn’t works^
Idk why I got problem with this.

try linking your account to github, if that does not work, create a new account will be that of your best bet

Hi @lillishaj, I had the same problem, try importing then type refresh in the console.

Hey @lillishaj the problem here is that you have a node_modules folder committed to your GitHub repo. Importing a repo with a node_modules directory won’t work in Glitch since Glitch expects to manage your node_modules directory itself.

If you remove that directory from the repo (or a fork of it) and import that, it should work, and you should end up with the same node modules installed once Glitch has completed the installation step.

Hope this helps!

1 Like

Thank you, it worked now.

1 Like