Connecting to Discord Error

Placed into Glitch Help as the error is on Glitch, not a Discord-sided issue

The bot worked perfectly up until a few hours ago when it randomly restarted and the following screenshot started happening:

Not sure how to fix it. Anyone got any ideas? It hasn’t been touched for a few days so idk what is happening.

My Live App link is:
Do note that for some reason the project refuses to wake up too!

Hi there!
Have you tried this in the terminal?

curl -I

Send the results over and I’ll have a look. :slight_smile:


1 Like

If my eyes serve me correctly and my brain functions, would I be correct in thinking Discord has temporarily banned the bot due to rate limits?


Your project has indeed been banned. Post your project name on the discord ban mega thread and Glitch will move you onto a different host.


Thank you for your assistance.

I highly recommended creating a watch.json.

1 Like

How and what does it do?

View my topic about the 429 issue. Anyway you can create a watch.json by this:

    "install": {
    "include": [
  "restart": {
    "exclude": [
    "include": [
  "throttle": 84600000

@SplitXPlayZ Can you explain to me exactly what Watch does? I’ve only recently started learning programming and I still have a lot to learn.

The watch.json will stops auto-restart so you cannot abuse the API by typing your code and the project will auto-refresh, a lot of these 429 issues are this problem.

Ah I see. But isn’t there an option for that with Glitch already? Just below where you make your project private? Or is that something else.

No, i guess. Glitch doesn’t have that yet.

Alright. Thanks for the help.

Anyway, do you have the 429 error still?

Nope. Discord removed the Rate Limit around an hour ago.

Oki, got it. :ok_hand:

1 Like