Error: Could not locate the bindings file, ENOSPC: no space left on device, write


#1

I have been facing this issue for the past two hours and idk how to solve it as ive tried anything i know.

this is the error:

/rbd/pnpm-volume/4d42fe1d-26cb-43dc-934f-47f7c781e273/node_modules/.registry.npmjs.org/bindings/1.3.0/node_modules/bindings/bindings.js:96

throw err

^

Error: Could not locate the bindings file. Tried:

→ /rbd/pnpm-volume/4d42fe1d-26cb-43dc-934f-47f7c781e273/node_modules/.registry.npmjs.org/better-sqlite3/4.1.1/node_modules/better-sqlite3/build/better_sqlite3.node

i contacted the database support and they asked me to “delete node_modules/bindings and re-install database
i couldnt do that so i removed node_modules entirely and wanted to re-install a fresh version
and this is what i faced:
npm WARN tar ENOSPC: no space left on device, write

whats taking up the space? ive removed all folders/files that i know take a lot of space…

i downloaded the project, and noticed how large the folder .git suddenly is…
i really appreciate any help, thanks


#2

Running enable-pnpm in the console might fix the issue


#3

can i give you like a bro kiss? :joy:
i deleted node_modules, git and re-installed everything. your command was the missing piece. really big thank you dude. and an answer only 30 minutes after my topic. really impressive


#4

rror: Could not locate the bindings file. Tried:
→ /Users/colonialmapper/Desktop/stuff/Bots/Colossal/node_modules/better-sqlite3/build/better_sqlite3.node
→ /Users/colonialmapper/Desktop/stuff/Bots/Colossal/node_modules/better-sqlite3/build/Debug/better_sqlite3.node
→ /Users/colonialmapper/Desktop/stuff/Bots/Colossal/node_modules/better-sqlite3/build/Release/better_sqlite3.node
→ /Users/colonialmapper/Desktop/stuff/Bots/Colossal/node_modules/better-sqlite3/out/Debug/better_sqlite3.node
→ /Users/colonialmapper/Desktop/stuff/Bots/Colossal/node_modules/better-sqlite3/Debug/better_sqlite3.node
→ /Users/colonialmapper/Desktop/stuff/Bots/Colossal/node_modules/better-sqlite3/out/Release/better_sqlite3.node
→ /Users/colonialmapper/Desktop/stuff/Bots/Colossal/node_modules/better-sqlite3/Release/better_sqlite3.node
→ /Users/colonialmapper/Desktop/stuff/Bots/Colossal/node_modules/better-sqlite3/build/default/better_sqlite3.node
→ /Users/colonialmapper/Desktop/stuff/Bots/Colossal/node_modules/better-sqlite3/compiled/8.9.4/darwin/x64/better_sqlite3.node
at bindings (/Users/colonialmapper/Desktop/stuff/Bots/Colossal/node_modules/bindings/bindings.js:93:9)
at Object. (/Users/colonialmapper/Desktop/stuff/Bots/Colossal/node_modules/better-sqlite3/lib/database.js:4:40)
at Module._compile (module.js:643:30)
at Object.Module._extensions…js (module.js:654:10)
at Module.load (module.js:556:32)
at tryModuleLoad (module.js:499:12)
at Function.Module._load (module.js:491:3)
at Module.require (module.js:587:17)
at require (internal/module.js:11:18)
at Object. (/Users/colonialmapper/Desktop/stuff/Bots/Colossal/node_modules/better-sqlite3/index.js:2:18)

I get that still, do you have any ideas?


#5

Hi @NieColon, welcome to Glitch!

We’ve noticed some problems with the pnpm package better_sqlite in that it seems to intermittently lose the mapping to the bindings file. Restarting your project (which either refresh or enable-pnpm in the console will do) seems to resolve it, but only until it pops up again. I’d suggest trying to run one of those commands again and let us know if that clears up your errors messages.