.Error: Could not locate the bindings file. Tried:

throw err;
Error: Could not locate the bindings file. Tried:
→ /rbd/pnpm-volume/00314e14-266f-417f-829c-3e126a185b2c/node_modules/.registry.npmjs.org/better-sqlite3/6.0.1/node_modules/better-sqlite3/build/better_sqlite3.node

I tried everything to fix that error, but not worked.
My project name: kyoya-api

Could you try enable-pnpm?

I tried it several times.

Could you share your package.json?

Ofcourse, https://hastebin.com/eliwarowas.json

have you tried rebuilding the better_sqlite3 module I believe it’s
pnpm rebuild better_sqlite3

Sadly, SQLite packages do not support v12. But, they do support v13 & v14 (as far as I know).

I was able to get it running, but I had to install it from the source, and install an apt package. So for now, use v11. It you are making a discord bot, you could remake the v11 package from discord.js for those who don’t want to make the big switch.


ahhh that explains better sqlite3 issues on my system. instead i just recoded auroraos to use endb

I’m pretty sure they do! I just changed my node js version from 8.0.0 to 12.0.0, typed refresh in the terminal and it works! The packages installed and they all seem to work correctly!

Here’s all my sql-related packages:
“better-sqlite3”: “^6.0.1”,
“better-sqlite3-helper”: “^2.2.1”,
“bindings”: “^1.5.0”,
“quick.db”: “^7.0.0-b22”,
“sequelize”: “^5.21.5”,
“sqlite3”: “^4.1.1”,

You’ll see a lot of sql install logs just wait until they’re done and your bot should be online.

Note: I know it might be tempting since the logs go on for a while but don’t refresh ok? (Generally don’t interrupt it)

1 Like

They may have patched it. Idk. Glad it works. :smiley: I got mine to work before by downgrading

1 Like