Import from GitHub cause some files missing

Hi, I have problem when importing from GitHub organization’s repo.
Some files are missing even when it says “Import successful” and “Connected”.
For example: at first attempt of import from GitHub, the “src” folder was missing. at the second attempt, the “public” and “assets” folder were missing, but the “src” folder was imported with empty index.js file (the code in index.js is not imported).
it would be great if someone could help with what cause the problem and suggest any solutions.
Thanks.

Open console from tools, and try command refresh. This would refresh your project. If didnt worked reply back.

Tried the refresh command and it didn’t work. Have to rewind to get back the missing files/folder. Tried the process couple of times, same thing keep happening. On other test glitch project using different account, was having the same problem yesterday, but today seems to work fine, but the main project remains with same problem.

In that case, you might wanna try cloning the repo into the Glitch project using Git.

Open the terminal and run

git clone <paste your git URL here> .

And then make sure to run refresh.