Node app suddenly having problems initializing

Hey there - I have a node app (Twitch bot) that is now having trouble initializing. The following occurs in the logs:

Installing...
Performing headless installation
ERROR  EACCES: permission denied, stat '/rbd/pnpm-volume/15d22c1e-a171-4243-9bfb-0c373ef9a744/node_modules/media-typer'

When I do an npm install in the terminal, I get the following:

npm ERR! code EACCES
npm ERR! syscall open
npm ERR! path /app/node_modules/tmi.js/node_modules/request/npm-shrinkwrap.json
npm ERR! errno -13
npm ERR! Error: EACCES: permission denied, open '/app/node_modules/tmi.js/node_modules/request/npm-shrinkwrap.json'
npm ERR!  { Error: EACCES: permission denied, open '/app/node_modules/tmi.js/node_modules/request/npm-shrinkwrap.json'
npm ERR!   cause: 
npm ERR!    { Error: EACCES: permission denied, open '/app/node_modules/tmi.js/node_modules/request/npm-shrinkwrap.json'
npm ERR!      errno: -13,
npm ERR!      code: 'EACCES',
npm ERR!      syscall: 'open',
npm ERR!      path: '/app/node_modules/tmi.js/node_modules/request/npm-shrinkwrap.json' },
npm ERR!   isOperational: true,
npm ERR!   stack: 'Error: EACCES: permission denied, open \'/app/node_modules/tmi.js/node_modules/request/npm-shrinkwrap.json\'',
npm ERR!   errno: -13,
npm ERR!   code: 'EACCES',
npm ERR!   syscall: 'open',
npm ERR!   path: '/app/node_modules/tmi.js/node_modules/request/npm-shrinkwrap.json',
npm ERR!   parent: 'tmi.js' }
npm ERR! 
npm ERR! The operation was rejected by your operating system.
npm ERR! It is likely you do not have the permissions to access this file as the current user
npm ERR! 
npm ERR! If you believe this might be a permissions issue, please double-check the
npm ERR! permissions of the file and its containing directories, or try running
npm ERR! the command again as root/Administrator.

npm ERR! A complete log of this run can be found in:
npm ERR!     /tmp/npm-cache/8.17.0/_logs/2021-06-10T12_37_45_942Z-debug.log

Any insight into what could be wrong?

Hi metalandcoffee! Welcome to the forum!

I saw another thread like this recently, where apparently the solution was to open the Glitch terminal and run:

enable-pnpm

Could you try it and let us know? :slight_smile:

3 Likes

Wow that worked! Do you know why that happened to begin with?

Great! :blush:

I could make something up, but essentially… no, I do not.