Packages will not install


#1

Hello. I am currently coding my Discord bot and I am trying to install a package, so I use the add-package feature, it is in my package.json, I have tried rebooting the project yet it will still not work. Why could this be and is there a fix? I hope there is. I have tried installing other packages and they wouldn’t install either. Thank you for reading.


#2

Hi!

Do you have a watch.json in your project? If that’s the case, then perhaps you don’t see the install step happening because of the value of the throttle option. Making a small change to watch.json will trigger the install immediately.

If that’s not your issue, please share the project name with us, and make it public if it is private, or share the join link with us in a PM


#4

Here is the log before it is telling me that the package can not be found when I try and reference it. and no, I haven’t made a typo

node v9.11.1, with pnpm
Installing…
ERROR This node_modules was not installed with the --shamefully-flatten option.
Don’t use --shamefully-flatten or run same command with --force to recreated node_modules
at …e_modules/supi/lib/api/getContext.js:69
at next
at fulfilled …de_modules/supi/lib/api/getContext.js:4


#5

Oh, I see. Strange that you got that error. Here is what you should do, in the console:

rm -rf node_modules/* node_modules/.*
enable-pnpm

And the error should go away :slight_smile: