Pnpm error halting all dependencies from being installed


Love Glitch so much! Just having a tiny problem with my project here.
Could you please advise on what might be going wrong? Thanks!

The following error is output to the logs when installing my dependencies:

node v8.11.1, with pnpm


 WARN  nodemon > chokidar: Skipping failed optional dependency fsevents@1.2.3

 WARN  babel-cli > chokidar: Skipping failed optional dependency fsevents@1.2.3

 WARN  webpack-watch-server@1.2.1 requires a peer of webpack@^2 || ^3 but version 4.8.1 was installed.

Packages: +907


 ERROR  ENOTDIR: not a directory, rename '/rbd/pnpm-volume/e17bc237-2cc5-4be0-a568-c921d46b9d0c/node_modules/' -> '/rbd/pnpm-volume/e17bc237-2cc5-4be0-a568-c921d46b9d0c/node_modules/'

After this error happens, I’ll get various module not found issues with my npm scripts that use npm-run-all or nodemon.

Thanks for taking a look!

Sorry for the problems - pnpm doesn’t like something. If you run enable-npm at the console, npm takes over and that seems to have no issue with it. Meanwhile, we’ll take a look into the pnpm issue.

1 Like

thanks for the speedy response!

I ended up rolling back Webpack 4 to version 3.x after a bit of research and discovering that version 4 shipped wasm support. It works now, so I suspect that was the problem dependency. Just in case anyone else sees a similar error.

This is very weird, it happens in one of my projects but not the other, I’m using webpack 4.6.0. I tried with several versions though. enable-npm fixed it but um you should fix this