Powershell script work in Alteryx Designer but not on Alteryx Gallery

I asked this over on the Alteryx forums and unfortunately didn’t get any answer. Hopefully someone here with Alteryx/PS experience will know the issue. I have a workflow that runs a batch file with a tabcmd command to export data from tableau into a csv in a share drive folder. Then a powershell script runs that reorders the columns, and moves them to another folder. Finally, a second powershell script runs, converts the csv to xlsx and exports that to another folder. When I run it locally in Alteryx Designer, it works just fine and I get the expected output. When I run it in [[Alteryx]](((Alteryx data Analytics | Tools and methods of Alteryx Data analytics) )) Gallery, the workflow completes with no errors but it doesn’t give me the expected out. It goes through the tabcmd step and the first powershell script with the correct output, but does not perform the second powershell script correctly. Please see below for script, the — are there to omit sensitive information.

$SharedDriveFolderPath = "\—\shares\Groups-–-–-–-–--\B"
$files = Get-ChildItem $SharedDriveFolderPath -Filter *.csv
foreach ($f in $files){
$outfilename = $f.BaseName +‘.xlsx’
$outfilename
#Define locations and delimiter
$csv = “\—\shares\Groups-–-–-–-–--\B$f” #Location of the source file
$xlsx = “\—\shares\Groups-–-–-–-–-–-–\C$outfilename” #Desired location of output
$delimiter = “,” #Specify the delimiter used in the file

Create a new Excel workbook with one empty sheet

$excel = New-Object -ComObject excel.application
$workbook = $excel.Workbooks.Add(1)
$worksheet = $workbook.worksheets.Item(1)

Build the QueryTables.Add command and reformat the data

$TxtConnector = (“TEXT;” + $csv)
$Connector = $worksheet.QueryTables.add($TxtConnector,$worksheet.Range(“A1”))
$query = $worksheet.QueryTables.item($Connector.name)
$query.TextFileOtherDelimiter = $delimiter
$query.TextFileParseType = 1
$query.TextFileColumnDataTypes = ,1 * $worksheet.Cells.Columns.Count
$query.AdjustColumnWidth = 1

Execute & delete the import query

$query.Refresh()
$query.Delete()

Save & close the Workbook as XLSX.

$Workbook.SaveAs($xlsx,51)
$excel.Quit()
}

I have serious doubts about this question being genuine, with (1) how widely it’s been posted around the web and especially (2) the odd commercial-looking URL that you tried to insert.

how about this: first, introduce yourself as a human being who has time to spend writing and reading this forum (as opposed to e.g. a human being who’s focused on broadly spreading around an advertisement); second, you do the work to set up a starter for users to play around with alteryx on Glitch; and third–and at no earlier time–we read and discuss the long unsolved issue that everyone on the internet seems to have with alteryx and powershell.

2 Likes