Python 3.6 support , is it possible?

I want to use Python 3.6.x but glitch runs Python 3.5.2 , on which some of my apps libs do t work :frown: So is there any way to do so? Also there is a apt package named libffi and also ffmpeg is there any way to install those apt packages too? I don’t if you can or cannot install them from pip or not …


Technically I’m sure it’s possible, however from what they’ve said currently only Node is officially supported.


If there’s anything I can do to help make this happen, let me know! I’ll send a PR in the right place :slight_smile:

1 Like

I would also really like this

Glitch has python3.5 & python2.7 installed. I’ve made a flask app here:


The containers that you run in, on Glitch, are Ubuntu 16.04.5, which has Python 3.5 pre-installed. Which distro/version should the containers be (to support Python 3.6+)? (note, it has to support node, go etc.)

I’ve tried creating a similar setup but in ruby and failed, how does flask actually gain access to do the routing? I’ve found that I’m no longer to gain access to bind to port 443 (which the web page appears to try to connect to) nor 80. I’ve seen glitch projects that make use of ruby on rails, but it won’t for me since the package is so large.

Hi @Unihedro, welcome to Glitch!

You won’t have access to port 443 inside your project; your project should expose your application on port 3000, and Glitch forwards port 443 to you container’s port 3000.

If you remix the python project listed above and execute the following code in the console (which you access from the Status pane revealed by clicking the Status button below your project’s name) you’ll see that your project’s container specifies port 3000 in its environment variables.

$ python3
>>> from os import environ
>>> print(environ['PORT'])

and if you look at the project’s you’ll see this:

# listen for requests :)
if __name__ == "__main__":
    from os import environ'', port=int(environ['PORT']))

where python starts listening on port 3000.

1 Like

With your hints I’ve successfully ported the flask app to barebones ruby and is on my way to making a proper project, it can be found here for anyone coming upon this in the future:

Python version 3.6.5 is the default in Ubuntu 18.04.
Do you think there is any chance this could be supported on Glitch?


Hi @xuv, welcome to ththe Glitch forum!

If you’re interested in the most recent python version, I recommend you vote for Can you upgrade python to latest version.

@cori Done.
For a second I thought you were directing me to a tutorial on how to upgrade Python to the latest version. Disappointment ensued.
In the meantime, I’ll move on to another service.
I do hope you can pick this upgrade story soon, your service is one of the greatest around.

1 Like