Unsure how to read these error messages


#1

Hi! I built a start kit that works fine locally but not on Glitch, and I’m not exactly sure how to read the following error message. Here’s my glitch: https://glitch.com/edit/#!/handsfree-starter?path=README.md:1:0

This dependency was not found:


* -!../../rbd/pnpm-volume/75d20ddf-c15b-4733-a7e4-8f3f84e1271c/node_modules/.registry.npmjs.org/cache-loader/1.2.5/webpack@4.25.1/node_modules/cache-loader/dist/cjs.js??ref--12-0!../../rbd/pnpm-volume/75d20ddf-c15b-4733-a7e4-8f3f84e1271c/node_modules/.registry.npmjs.org/babel-loader/8.0.4/@babel!core@7.1.6/node_modules/babel-loader/lib/index.js!../../rbd/pnpm-volume/75d20ddf-c15b-4733-a7e4-8f3f84e1271c/node_modules/.registry.npmjs.org/vuetify-loader/1.0.6/node_modules/vuetify-loader/lib/loader.js!../../rbd/pnpm-volume/75d20ddf-c15b-4733-a7e4-8f3f84e1271c/node_modules/.registry.npmjs.org/cache-loader/1.2.5/webpack@4.25.1/node_modules/cache-loader/dist/cjs.js??ref--0-0!../../rbd/pnpm-volume/75d20ddf-c15b-4733-a7e4-8f3f84e1271c/node_modules/.registry.npmjs.org/vue-loader/15.4.2/css-loader@1.0.1/node_modules/vue-loader/lib/index.js??vue-loader-options!./App.vue?vue&type=script&lang=js& in ./src/App.vue?vue&type=script&lang=js&


To install it, you can run: npm install --save -!../../rbd/pnpm-volume/75d20ddf-c15b-4733-a7e4-8f3f84e1271c/node_modules/.registry.npmjs.org/cache-loader/1.2.5/webpack@4.25.1/node_modules/cache-loader/dist/cjs.js??ref--12-0!../../rbd/pnpm-volume/75d20ddf-c15b-4733-a7e4-8f3f84e1271c/node_modules/.registry.npmjs.org/babel-loader/8.0.4/@babel!core@7.1.6/node_modules/babel-loader/lib/index.js!../../rbd/pnpm-volume/75d20ddf-c15b-4733-a7e4-8f3f84e1271c/node_modules/.registry.npmjs.org/vuetify-loader/1.0.6/node_modules/vuetify-loader/lib/loader.js!../../rbd/pnpm-volume/75d20ddf-c15b-4733-a7e4-8f3f84e1271c/node_modules/.registry.npmjs.org/cache-loader/1.2.5/webpack@4.25.1/node_modules/cache-loader/dist/cjs.js??ref--0-0!../../rbd/pnpm-volume/75d20ddf-c15b-4733-a7e4-8f3f84e1271c/node_modules/.registry.npmjs.org/vue-loader/15.4.2/css-loader@1.0.1/node_modules/vue-loader/lib/index.js??vue-loader-options!./App.vue?vue&type=script&lang=js&

I’m using Vuetify with the Vue CLI Plugin, basically this repo with the addition of stylus-loader and pug-loader. I’m not sure what exactly it wants me to install.

Thanks!


#2

Hi @labofoz sorry for the inconvenience! I’m not sure exactly how to read that either, but I’ll take a look and let you know what I find!


#3

Thanks! I created a new project with literally only this:

vue create my-app
cd my-app
vue add vuetify

I then committed whatever was in that repo and imported it from GitHub into Glitch as-is. Then I changed the start script from serve to start. That’s literally all I did, and I get the same error. I see the phrase “cache” a lot in the error, could it be a caching issue? Or does Glitch not yet support Vue CLI 3?

Update: I ended up just building it offline and importing it into Glitch that way. I think it might be related to Vue CLI 3, but for now I got it to work :slight_smile:


#4

Glad you got it to work - I’ll have a look at the Vue CLI and see if there’s some sort of blocker there.


#6

Hey @labofoz I know you’ve moved on from this, but I thought you might be interested that this issue seems like it might be related to a bug related to pnpm usage in vue-cli.

I remixed your handsfree-starter project and rewound to the point when it was still running vue-cli-service serve on start. Then I switched it to npm (which required me to temporarily grant it some extra space for testing) and then handled a few errors by using npm install caniuse-lite and npm install vuetify manually and the project started. Doing the same manual install steps in pnpm did not resolve the issue.

I ran into similar problems starting from scratch with "@vue/cli": "*" in my package.json and using your commands

vue create my-app
cd my-app
vue add vuetify
npm run serve

where my-app's package.json has "serve": "vue-cli-service serve". Switching to npm there also got me through these super-byzantine errors (to a whole new set)


#7

Wow thanks cori! Actually I haven’t moved from this yet and have been restrategizing my whole approach to these starter kits so I’m glad you were able to look into it more!

This will help me git push directly into Glitch, I’m super excited. I’ll let you know how it goes across my other projects, thanks again for investigating!


#8

I’m not sure how much it will really help you with pushing directly to Glitch - at least on the one I was working from, switching to npm was disk-space prohibitive so I don’t necessarily think it’s a long-term solution.

I also never got either of the projects to what I would call a working state, not least because I know next to nothing about VueJs. But if you’re still actively working on this I can try to spend some more time on it - it would be great to have a streamlined workflow for these projects.


#9

No worries, this is still very helpful as it gives me a starting point. I’ll keep you posted either way!