Uptime Robot doesn't work with Python and shows downtime

Please consider providing your Glitch project’s name in your post. Many problems are very difficult to troubleshoot without being able to see the code involved. Users who haven’t been invited to your project won’t be able to edit your code or see the secrets in your .env file just from your project name.

Alternatively provide some code that gives community members some context around your problem. Use the code formatting tool to make your code easier to read.


Gif credits: Uptimerobot not working - discord bot

I am making a discord bot using python with Discord.py library!

Here’s my project link

Here’s my config



Thank you very much for your time!

1 Like

I took a look at your project and then did some reading in the discord.py documentation and the problem seems to be that your project never opens a web server to handle the Uptime Robot ping. As far as I can tell discord.py establishes a connection with the Discord Gateway directly, so I doesn’t actually handle incoming requests from the larger internet.

I would add a lightweight endpoint with either Flask or Django for Uptime Robot to ping, that would start your project and then in turn startup your discord implementation.

1 Like

Can you please show how? @FlantasticDan

Glitch has a starter app for flask that should serve as a good example. Just make sure to add a call to the discord.py entry point inside of the if __name__ == '__main__' block.

Now what should I do now?
I am using https

@FlantasticDan and also the hello from doesn’t show when I tried to open the app here!

Down again
@FlantasticDan

It gave some uptime for 3hrs then down again!

And also it was not showing this one.
image

Well, the bot is online but the uptime robot doesn’t shows uptime

That lil icon is there because you are using websockets (from connecting with Discord)

What you mean @youngchief_btw?

But it wasn’t there for some time though. And the bot worked correctly without problems.
And also the uptime robot showed the uptime correctly!

@FlantasticDan I am getting this error, Idk why?


And also the lil icon gone @youngchief_btw

And also I can’t find any errors on the project logs though


Here is the picture showing the Host number with Port number
And here’s the project log

You are supposed to use the project domain not the IP if you can (because Glitch uses reverse-proxies and stuff) btw

Well
It shows me the code error
But I can’t find any
please help

Anyone help?
I have the same problem.

Please help
I have been in trouble wit h keeping my project online. Please help
And it is down for 213hrs
Please help