URGENT: Glitch is down

According to the Glitch status page, Glitch projects have been fully down for approximately an hour now. This is highly disappointing and an update from engineers to confirm they’re looking into it would be appreciated. @jenn

1 Like

Hi! Thank you for mentioning this.

This almost looks like a hack (was the edit button always a pants emoji?)

Anyway it appears that on the status page they say (and I quote)

Identified - We’re investigating an incident involving malicious use of the puppeteer package, it may lead to projects running puppeteer being suspended.

It also appears that this issue has been going on since January 30th. I would like some admin confirmation on this issue, please…

I was going to visit a game when suddenly it said “504 Gateway Time-out”.
when i tried to fetch a text using my discord bot it said this code:

<head><title>504 Gateway Time-out</title></head>
<center><h1>504 Gateway Time-out</h1></center>

what should i do now?

This is the issue. There is nothing you can do. It is in the hands of the Glitch developers to fix it, for now, go play some other game that is out of glitch. Sorry about the inconvenience.

1 Like

I don’t think the puppeteer issue is related. The issue here seems like another DDoS attack which Glitch experienced another previous outage as a result of. They need to gear up their systems properly to prevent these kinds of attacks.

But the project does not use puppeteer and it is axios, discord.js and eris

This might be nothing, but…

huh? What do you mean by this?

my project is node.js and only runs axios, discord.js and eris in package.json
but that is also still down

only somehow discord itself can access the bot without the gateway timeout and when i use commands on the bot, IT WORKS PERFECTLY FINE

Oh I see what you are saying.

The glitch is causing other projects to be down. Glitch deliberately took down puppeteer projects so they could try to solve the problem, but the problem has caused issues that caused certain projects to fail.

So the problem is with the domain and the client which cannot access it, not the discord itself that can make the bots execute the commands smoothly with 97 ms?!

i tried to set up a static site by copying all the code and pasting it in replit and running the site as an alternative, BUT THEN IT SAYS “hmm… cannot reach this project”

Replit also removed their free plans now i don’t have any choice other than waiting… Thank you puppeteer misusers

That was the worlds saddest thing. I had a discord bot that was running great, and was AI, but then the plan removed free Flask domains, so I couldn’t keep it up… SO SAD. :frowning:

Hi there - I am just catching up on what’s going on and I apologize for the late update on this. The team has identified the issue, put out a fix and are monitoring the after effects. Associated status page for future updates Glitch Status - Issues routing requests to projects