Bug fix might cause some projects to fail


#1

Hi everyone

our backend parses package.json to detect which version of Node it should use to run your application. Since yesterday, our code had a bug that prevented it from “guessing” correctly the right version in case the one specified in package.json isn’t present in the backend.

For example, if your package.json specifies:

...
  "engines": {
    "node": "4.4.5"
  },
...

it will now pick the “closest” version available, 4.4.7, but before yesterday, it would have picked 6.9.1, as it was the “global” default version.

This means that if you use in your backend features that are only available in more recent versions of Node, your code will abruptly fail to run, and you need to update your package.json consequently.

We suggest you to specify only the major and minor version, like this:

  "engines": {
    "node": "7.7.x"
  },

Sorry for the inconvenience!


What is causing this fiber error?
#2