Cannot find module this morning when last night it worked

last night it all worked and i went to sleep and woke up and it doesn’t.
It says it cannot find the module ‘fastify’ even tho i didn’t change anything since it was working.
Luna’s Blog did this once too and i then copypasted the entirety of Celestia’s Blog over Luna’s and Luna’s worked again. Makes no sense at all to me. Implies there was something in Luna’s code that was wrong and had to be overwritten, but without me having edited it and with the error being ‘cant find module’ for a module it could find last night and is a starter module that is in base projects. My new project is doing this. just doublechecked and the package.json is identical to my projects that do work and importing the same fastify as they do. Yet the error seen above in Allo Beautiful

have looked and seen similar historic issues and tried enable-pnpm and enable-npm and still error

i can cut all the code so it’s just

const fastify = require("fastify")({
  // Set this to true for detailed logging:
  logger: false

and the package.json which is basically identical to my others that work, and still the error. so it’s nothing in my code doing this as far as i know

Hi @Allo - can you share this in a ticket at and someone from support will be able to look into why this is happening. I don’t think this is a code error on your part, but we’ll need to see why suddenly your project isn’t getting its dependencies.

1 Like

thank you, i will :slight_smile:

edit: yay it works already. Thank you!!!

1 Like

can you check the logs to see if npm failed to install the dependencies for you?

I’ve found that there can be situations where glitch proceeds to run your app even when the “install” step fails

1 Like

it always said it did install correctly.

Though I today looked over package.json, which I am a noob at, and researched a bit and found I had changed the name to “Allo Beautiful” thinking it was up to me what I named it and not that it was a place i had to retype something from somewhere else. And similarly it’s Repository field had been ‘sqlite’ still long after i had remixed it in to something else. so i assumed the field was vestigial and removed it. since, after i removed it it still worked, i assumed nothing bad had happened. Perhaps these are related to why, later in the night, it mysteriously stopped working. thank you :slight_smile:

edit: tho i have had Celestia’s Blog, Luna’s Blog, and Beautiful, and all three I had no repository and misstitle. Yet Celestia’s Blog has never had any problem. So probably those two things didn’t cause it (or it’s a multifaceted issue).

thanks, that rules one thing out.

I feel like the package name and repository fields shouldn’t cause that. I usually don’t set either.

1 Like